Saturday 23 March 2019

Java Substring Example

Problem:-
Given a string, , and two indices,  and , print a substring consisting of all characters in the inclusive range from  to . You'll find the String class' substring method helpful in completing this challenge.
Input Format
The first line contains a single string denoting .
The second line contains two space-separated integers denoting the respective values of  and .
Constraints
  • String  consists of English alphabetic letters (i.e., ) only.
Output Format
Print the substring in the inclusive range from  to .
Sample Input
Helloworld
3 7
Sample Output
lowo
Explanation
In the diagram below, the substring is highlighted in green:
substring.png


Solution:-

import java.io.*;
import java.util.*;
import java.text.*;
import java.math.*;
import java.util.regex.*;

public class Solution {

public static void main(String[] args) {
Scanner in = new Scanner(System.in);
String S = in.next();
int start = in.nextInt();
int end = in.nextInt();
System.out.println(S.substring(start,end));
}
}


No comments:

Post a Comment

Error While embed the video in Your website page

Error:- Refused to display '<URL>' in a frame because it set 'X-Frame-Options' to 'sameorigin Solution:- if ...